Back to overview
Maintenance

Forum maintenance

Jun 13, 2026 at 3:40pm UTC  –  Jun 13, 2026 at 4:00pm UTC
Affected services
Forum

Resolved
Jun 13, 2026 at 4:00pm UTC

Maintenance ended

Created
Jun 13, 2026 at 3:40pm UTC

Updating our forum software.